"Your device isn't compatible with this version" Help.

Fusei

New Member
Joined
10/07/2017
Messages
1
Hi guys I checked the (locked) sticky thread, did everything, didn't fix the issue. (Got a samsung galaxy j1 with 1gig ram).
Also contacted google play.

So I downloaded one them apk to see if the game would work or not on my device. It does.

Thing is I want to support indie developers. Honest, I unistalled the app and came here to get it legit (and without malwares).

Bottom line, if you guys have any tricks up your sleeve. I would appreciate it, otherwise well on my next phone !

Cheers.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
7,466
That is certainly strange... J1 is marked as compatible and many users have even purchased the game. Can you please try to delete cache from Play Store and restart your device? Sorry for the inconvenience.
 

Top