UI bug on Android

JarrenDrahn

Member
Joined
14/05/2017
Messages
155
Found this bug across all saves and new games today. Restarting doesn't seem to fix it.

I'm on a Samsung A8 on the latest version. It did recently update with a new UI. Something called Android Pie 9.0.
 

Attachments

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
6,009
Seems like a game font is missing... please try a reinstall.

Android 9 pie is not an UI, is a new version of Android. While I don't own any android 9 device to test it myself, we already have thousands of downloads made by Android 9 devices, and over 300 ratings, so I think there is no incompatibility with Android 9. Please let me know if a reinstall of the game fixes the issue.

Before uninstalling, make sure you backup both in file and cloud!
 

JarrenDrahn

Member
Joined
14/05/2017
Messages
155
Thanks, uninstalling and reinstalling worked.

I just made an assumption about the Android update because it mentioned UI on the version and my phones entire UI changed. :D
 

SrbskyKral

New Member
Joined
04/05/2019
Messages
3
Hi,
I have exactly same issue - reinstall helps only for first launch. After closing app and starting it again - it happens again (missing text like in picture in first post). I restored game after a month from the cloud. Everything was ok before. In meantime i had Android update too.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
6,009
SrbskyKral":2q2dd7bb said:
Hi,
I have exactly same issue - reinstall helps only for first launch. After closing app and starting it again - it happens again (missing text like in picture in first post). I restored game after a month from the cloud. Everything was ok before. In meantime i had Android update too.
What device and android version are you using?
 

JarrenDrahn

Member
Joined
14/05/2017
Messages
155
The problem returned again for me too. Uninstalling an reinstalling fixes it temporarily but the text vanishes again on exiting the game and reloading.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
6,009
Are you using any settings to replace the text fonts in the new UI?
 

JarrenDrahn

Member
Joined
14/05/2017
Messages
155
Everything is set to the default settings on my phone itself. And I definitely haven't done anything to alter exiled kingdoms itself.
 

SrbskyKral

New Member
Joined
04/05/2019
Messages
3
DavidBVal":dvy2wokn said:
SrbskyKral":dvy2wokn said:
Hi,
I have exactly same issue - reinstall helps only for first launch. After closing app and starting it again - it happens again (missing text like in picture in first post). I restored game after a month from the cloud. Everything was ok before. In meantime i had Android update too.
What device and android version are you using?

Huawei P20lite, android 8.0.0
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
6,009
SrbskyKral":1g1910tb said:
DavidBVal":1g1910tb said:
SrbskyKral":1g1910tb said:
Hi,
I have exactly same issue - reinstall helps only for first launch. After closing app and starting it again - it happens again (missing text like in picture in first post). I restored game after a month from the cloud. Everything was ok before. In meantime i had Android update too.
What device and android version are you using?

Huawei P20lite, android 8.0.0
Then we can discard this is related to Android 9 (pie)... very strange.

I checked my Play Store stats... I have dozens of recent 5 star reviews from P20lite and Samsung A8 users, so I don't think this is an incompatibility with those models either.

Maybe you have installed recently something that could be affecting how other apps are installed? a launcher app, or something font-related? maybe related to accessibility.
 

Top