New hosting for forum and wiki

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
5,990
As you might have noticed, we've been under attack recently, both spam and DDOS attacks; to make matters worse, my hosting provider decided to shut me down for 24 hours without even telling me the reasons.

Over the weekend, I've been migrating to Bluehost, which should give a much better service, and a faster response for american visitors as well (two thirds of visits).

Everything should be working fine, and the databases (both forum and wiki) were imported without problems, so no data was lost. But of course there might be some small details here and there I forgot to update, or an extension that might not work; if that's the case please notify me so I can fix it.
 

Board Troll

New Member
Joined
12/04/2016
Messages
525
Looks like the shoe salesman has invested in a 50 dollar piece of software and attacked us because we didn't care for his Nike ads.

I was a little worried yesterday, glad you got us back up.
 

Alan_SP

Staff member
Administrator
Joined
11/01/2016
Messages
1,508
Found image that looks like garbage, probably problem with site transfer: viewtopic.php?p=13453#p13453

Hope most important things are fine (especially wiki images and databases). David, do you still have access to files on old server? To check consistency.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
5,990
Database is fine, it is double-checked. All the wiki images are there, and no forum post was lost. Attachments, I am not entirely sure why they would fail, as every file has been copied... it's obvious some attachments are not working well, but oddly enough others are fine.
 

feldon

Loreseeker
Joined
18/04/2016
Messages
1,352
I was noticing attachments dropping prior to the changeover, so it wasn't directly caused by the switch. Might have made the issue more pronounced.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
5,990
I restored all the attached images from the old server, but you may need to hit Ctr+F5 to refresh images and see them correctly.

technical explanation:

PHPBB stores uploaded attachments as files named with a hash, and without extension. My FTP client (Filezilla), and most other FTP clients, convert files without extension into ASCII, instead of binary, corrupting them completely. This is easily avoided by changing the settings and telling it to always download as binary. Lesson learned for the future.
 

Alan_SP

Staff member
Administrator
Joined
11/01/2016
Messages
1,508
Don't get it why they use ASCII transfer at all, when everything (every file) is just fine with binary transfer. Probably for legacy reasons.
 

Top