Lags on steam version

BloodShashl

New Member
Joined
11/05/2021
Messages
3
Hello, sorry for my bad english.

I have a lag in the Steam version of the game(Drop Fps to 1 for a couple of seconds).During the closing of the inventory, the dialogue menu or when the caption pops up.Occasionally lags during combat, especially in the dungeon.
I noticed that I have version 1.2.1118, but the latest version is 1.2.1124. I can't update it in any way, rebooting the PC and Steam does not help me.
Please help (
 

VDX_360

Staff member
Moderator
Joined
20/01/2017
Messages
3,464
Could the issue be performance issue with your computer, or device?
 

BloodShashl

New Member
Joined
11/05/2021
Messages
3
No, I definitely have enough pc power)
I tested version 1.2.1124 and everything is fine on it, but why is it not in steam?
My purchased game is downloaded with version 1.2.1118
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
6,334
Please try the Steam Beta, just to make sure if version makes a difference.

On your game library, right click on the game, go to the Beta section and add the password EKbetatesting
 

BloodShashl

New Member
Joined
11/05/2021
Messages
3
Please try the Steam Beta, just to make sure if version makes a difference.

On your game library, right click on the game, go to the Beta section and add the password EKbetatesting
I did as you said and the problem remained (
I tried to run as administrator, change the screen resolution, enable compatibility, enable and disable simple fonts, change the language ... It's all useless.
Apparently the problem is the steam.

MODERATOR EDIT: subject not allowed in forums
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
6,334
Other Steam users have never reported this, so I suspect a corrupted installation.

Have you tried a complete reinstall of the Steam game? deleting the whole exiled kingdoms folder, then downloading again.

Alternatively you can ask for a refund and then get the game at GoG
 

VDX_360

Staff member
Moderator
Joined
20/01/2017
Messages
3,464
It's unlikely, but you could try to re-install Steam.

This is not an issue I've seen reported before either....
 

Top