Attacks not hitting / Potions not working

FrizkyWyzard

New Member
Joined
01/10/2017
Messages
3
Hi, I searched to see if this was already posted but didn't find anything.

Midway through a dive into the Kingsbridge bandit hideout I suddenly was not able to hit my opponent.
The animation was playing but there was no effect. I thought maybe I wasn't close enough, so I repositioned but still no hits. Since I was a sitting duck I had to retreat. Near death, I used a light healing potion but to my dismay was no effect. I managed to make it out of the dungeon alive though.

I was playing lvl 4 Rouge on Ironman. Also this has never happened during my 50+ hours playing normal difficultly. I hope this isn't some Ironman feature I'm not aware of xD

Any help with this would be appreciated as now I'm scared to play my Ironman character.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
7,466
Hello, if the glitch persists after a sleep at the inn, please export your data (continue Game>export&cloud) and then email me the file to [email protected]
 

FrizkyWyzard

New Member
Joined
01/10/2017
Messages
3
Happened again on a warrior. Sleeping at an inn or loading a new map makes it stop. Playing a cleric now and it hasn't been an issue. I appreciate the quick response. Tried to trigger it on the warrior but haven't been able to reproduce it. If it becomes a persistent issue I'll send you the .bak file. Thankyou!
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
7,466
Odd that an issue that had never been reported before happened to you twice.

Were both times with an ironman character? did anything special happen on that game?

What device and android version do you have?
 

FrizkyWyzard

New Member
Joined
01/10/2017
Messages
3
Yes, both characters it happened to are Ironman. Nothing out of the ordinary, no other bugs or glitches.

I have a ZTE Sonata 3(Android 6.0.1), terrible phone, I know. I'm surprised it ran EK at all, but like I said I played like 50+ hours on normal with no issues, other than probably longer than usual loading times and occasional frame lag in the bigger cities.
 

Taurossilva

New Member
Joined
07/11/2016
Messages
102
This has happened to me before in the sunken citadel. The difference being: not only can i not hit my opponent, but neither do they do damage to me. If i leave the dungeon and come back a few times, then it goes back to normal. Also, a couple of times, I'd be shooting arrows at an opponent that is obstructed by something and they regenerate whatever damage i do to them. I have to close in and use my hand weapon to kill them.
 

DavidBVal

Developer
Staff member
Administrator
Joined
28/02/2015
Messages
7,466
Whenever any of you is in a similar situation, please send me your data.
 

Kuratha

Staff member
Moderator
Joined
12/02/2017
Messages
174
Lol, just as I was sitting down to write about this I see this post.
I'll send you my data when I can.

I've experienced this recently in the Sunken Citadel and the Ark of Lothasan. I could not damage the enemy nor could they damage me. I've also found that the first hit that would have hit them affected them can still apply status affects. If my trap hits them they receive no damage but receive the slowed debuff for an infinite amount of time. My first shot that would hit them with stun would stun them for an infinite amount of time. Companions would attempt combat accordingly and were always aggroed on this enemy if not stunned or slowed. Resetting the instance seemed to fix this anomaly.

I've only found this problem to occur while playing a rouge and have suspicions that it has to do with the EVASION skill. Sometimes instead of a missed notification overhead I'll receive a 0 dmg one. I've further noticed that this only occurs with mobs that attack with elemental attacks, more often with electric ones. Sunken Citadel, Minotaur priests, Ark, Steel Wizard's, Skeleton Priests, Abbey, Hags/Witches, Imperial Fortess, Batrax Theurgist.

An issue of checks vs resistance still triggering through an evasion check?

Hope this helps you narrow the problem down~!
 

Tschis

New Member
Joined
26/10/2017
Messages
16
Hello!

Just to add to the discussion, this guy is describing the same problem, but his thread is in Portuguese so you probably didn't understand:

CristianoR":33l4fk42 said:
Translation:
Hi guys, I'm training a Rogue and using stealth+sneak attack, attack + stab strategy. But this is failing to hit and I am also unable to heal, it could be a bug. Can anyone check? Thank you for your attention and sorry if I posted on the wrong place.

Original:
Oi pessoal,estou treinando um gatuno e usando a estratégia stealth+sneak attack+stab. Mais essa combinação está falhando e sem a possibilidade de usar pote de cura.pode ser um bug. Alguém poderia verificar por favor?.obrigado a atenção e desculpe se postei no lugar errado.
 

Top