1. vanderson

    bug in kurgar cave. side quest: snake Gang

    bug in kurgar cave. side quest: snake Gang. DESCRIPTION BUG: once you enter the red door (mission) and you go outside without completing the mission, you can't enter again, even if you have 'scorpion poison'. I can't complete or finish the mission due to this problem, can anyone help me...
  2. Tordak Karamas

    Ankh's Mistake

    Good day, exiles. Yesterday my hardcore for a warrior ended in death. I died the death of brave legionnaires, dying from disgusting trolls. My Ankh didn't save me from an unexpected death, although it was definitely in the bag. What is this evil joke on the first of April? Help.
  3. -𝕴𝖛𝖊𝖟-

    [bug] skill issues (infantry training)

    The "stun immunity" in the passive skill "infantry training" is not working. It's working when i maxed it out but After closing the game and open it again The issue occurred
  4. SoyAlek

    Bug Bug: lost in a good book

    when entering the dungeon the food does not appear in any of the chests and the error is not solved by restarting the game
  5. TheVoidGaurd

    Bug Bugs and error

    I had to get a new phone. But I had a cloud save I bought full game and. I restored full game but when I try to restore my save from cloud.. my lvl 20+ character save. I get this 😭😭😭😭 Screen shot of error https://drive.google.com/file/d/1-8vCqV65Qgn3sLuqJIgLvUt28RwNM8XV/view?usp=drivesdk

    Mirmek Nest is impossible to get destroyed

    Hey there, did anyone can help me out. I can't destroy the first Mirmek Nest. (The Quest for Sheryl and this ummm racist Nisor Its pooping out new Mirmeks but isn't even scratched. I even tried reloading but I haven't set a permanent save because it is early in the game. Mod Note: Deleted...
  7. Wellen Arren

    Solved Got refund but didn't want to

    So, here's the problem: Three days ago I bought the Full License, okay, but today I received an email from Google regarding me getting full refund, but I didn't want a refund. Is there some way I can solve this?
  8. ExiledAdrian

    [Bug] Kicks out of the game.

    Does this happens to anyone? I just bought the full license on iOS. I created a new mage character, everything went totally fine the first 10 min or so. But now, sometimes when i go inside a city, dungeon, etc; it kicks me out of the game. Its not too much of a problem because i can get back...