Search results

  1. J

    Defending the Outpost

    Ah, didn't realise it was just ordinary boss loot and not guaranteed. I wasn't trying to reload for specific drops, I know they're fixed anyway. I just thought it was bugged because he didn't drop anything. Now I know better.
  2. J

    Defending the Outpost

    Does Ahroun no longer drop anything? I noticed after I killed him he didn't drop any boss loot. I thought maybe it was an outpost defender that got the final blow? So I reloaded and killed him myself with no help and still nothing.
  3. J

    Item update thread

    I just noticed there are no Thuramiam leggings in the game. It would be nice if they were added to complete the set. Also, another way to get the thuramiam breastplate. The one place you can get it interferes with the ending. It's also right before the ashen set becomes available rendering it...
  4. J

    How do I become a tester

    I'll make this clear for you. The game designer is one person. He has previously stated on this very forum that production on this game has finished, ceased, it is no more, a dead parrot. He is now working on a new game. It will take him 2-3 years to finish that game. Only after he has finished...
  5. J

    Help with pure rogue archer!

    The AI seems to target the person doing the highest DPS from what I can tell, which is usually the player.
  6. J

    Login to Google Play Games not working

    I had this problem. I checked google play and found and update for EK. As soon as I updated the problem was resolved.
  7. J

    Isnt it kinda unfair that trapped enemies regenerate why I suffer(Archer)

    I will say that sometimes the AI will be attacking a companion, but then aggro onto the player due to higher dps. They will attempt to move past the companion and get stuck causing them to regenerate. Then they attack the companion again, aggro back onto you, regenerate and repeat until your...
  8. J

    Underlevels in Icemist Need a much harsher warning before entering!!!!!

    Unless you were playing on ironman (which you said you saved before hand so that's unlikely), you have access to 4 hard save slots, a quick save slot, area auto save and the auto save whenever you rest at an inn. You're saying you only have 1 save you've used this entire play through? I always...
  9. J

    Forum is upgraded from phpBB to XenForo - please report if you have any problems here

    Something about the new design and features seemed familiar to me. It looked very similar to a forum I was on over 10 years ago. Turns out XenForo is made by former developers from vBulletin which explains the similarities. Anyway, it looks great. The ability to check all new posts is...
  10. J

    Regarding the Peaceful Ending

    I have had the peaceful ending with every class no problem. There are plenty of skill points to boost your primary traits and still get other skills up by the time you hit end game. Also, you only need 3 awareness as you can use the goggled helmet to get +2 and boost you to 5. Likewise...
  11. J

    Official Wiki Corrections and Suggestions Thread

    The gems page on the wiki should include the quest A Fair Deal next to the small ruby.
  12. J

    gems?

    There is one missing from the wiki. A small ruby is needed for the quest A Fair Deal in order to get the Cloak of the Wolf from Janod.
  13. J

    Report *TEXT & TRANSLATION* issues here

    I never noticed this before because I usually save Laertes but in the English text the ring of charm says "Irradiates a mystical aura", this should be "Radiates a mystical aura".
  14. J

    Archaelund (now updated with screenshots and video!)

    The armour on those 2 remind of some of the designs in Skyrim.
  15. J

    UI bug on Android

    I tried uninstalling and reinstalling again but the text isn't returning this time. I wondered if it was something to do with the game launcher on Android so I removed it from there and tried a fresh install. It still didn't work however and the text is still missing on all save files. Even...
  16. J

    UI bug on Android

    Everything is set to the default settings on my phone itself. And I definitely haven't done anything to alter exiled kingdoms itself.
  17. J

    UI bug on Android

    The problem returned again for me too. Uninstalling an reinstalling fixes it temporarily but the text vanishes again on exiting the game and reloading.
  18. J

    WTF

    Also, when you're farming, are you killing the monster then reloading the save if you don't get the item you want and killing the same monster again? Because if you are it's drops won't reset. It will drop the same thing every time. You have to do a long rest at an inn to make the monster...
  19. J

    UI bug on Android

    Thanks, uninstalling and reinstalling worked. I just made an assumption about the Android update because it mentioned UI on the version and my phones entire UI changed. :D
  20. J

    UI bug on Android

    Found this bug across all saves and new games today. Restarting doesn't seem to fix it. I'm on a Samsung A8 on the latest version. It did recently update with a new UI. Something called Android Pie 9.0.

Top