It is currently Wed Dec 11, 2019 11:34 pm

All times are UTC

Post new topic  Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sun Nov 18, 2018 7:03 pm 

Joined: Fri Nov 16, 2018 4:47 pm
Posts: 4
Got on steam this morning to play Exiled Kingdoms and it said there was an update. Started the update many times it locks and says the file is corrupted. Funny thing is I thought there were no more updates for this game and this update is 113 megs. So, just bought the game a SECOND time from steam to play without KOplayer on my computer and it now won't play AND my character updates cannot be retrieved without the update. What is going on with the steam version????

BTW i went through all the purge/repair stuff that steam suggests. Even made a new foloder for downloads.

PostPosted: Sun Nov 18, 2018 8:47 pm 
EK Developer, Admin
User avatar

Joined: Sat Feb 28, 2015 11:00 am
Posts: 5813
Has thanked: 384 times
Been thanked: 695 times
Well, you can't purchase a game twice on Steam as far as I know. Once your game is in your library, you can't add it again, unless I am mistaken.

No one has reported similar issues with the game and it's selling normally today and getting active players as usual, so very likely there must be an issue with corrupted files or connectivity on your end. A clean install should work. Have you completely uninstalled the game and removed the game folder (under steamapps folder) before trying to install again?

Maybe your issue about updating is related to steam cloud saves. If everything fails try to go to the game properties on your steam library and disable cloud syncing.


PostPosted: Sun Nov 18, 2018 9:04 pm 

Joined: Fri Nov 16, 2018 4:47 pm
Posts: 4
No, I bought it on android and made the decision to buy it again on steam. It really is smoother game play vs Koplayer app on PC. It doesn't seem to be on my end. As i said I cleared cache, changed download folders, changed servers to download from, and tried several times to download it. On steam's end it says the file is only 113 megs. Also, why am i getting an "update" if there is no new version. I was trying to make you all aware that something was amiss. Furthermore I downloaded a new game because I can't play Exiled Kingdoms and it went fine.

PostPosted: Sun Nov 18, 2018 10:03 pm 

Joined: Mon Jan 11, 2016 9:08 pm
Posts: 1317
Has thanked: 180 times
Been thanked: 92 times
You didn't had Steam version before, you had Android version? Or you first had Android, then you bought Steam, and then you again bought Steam?

As David said, you don't need to purchase game on any platform twice, once is enough (don't know if it will be possible with same account, I guess you can do that if you somehow have two or more accounts, but it is like you're two or more people, don't know how it works on one device). You only need to purchase game for each platform (PC, Android, iOS) again if you want to play it on that platform.

After that, you install game on wanted device(s) and you need to manually copy save files (EK.bak). Cloud save doesn't work with Steam, you need to do this manually, you can't do that through Steam, Steam cloud or anything Steam related.

Anyway, I just tried and started right now my Steam version, it is 1.2.1115. And it worked just fine.

PostPosted: Wed Nov 21, 2018 3:00 pm 

Joined: Fri Jan 27, 2017 2:31 am
Posts: 1380
EK Translator: German
Has thanked: 65 times
Been thanked: 242 times
You should try to reinstall the game and if that won't help the steam client. I had similar problems with other games on steam several times.

OT deleted

Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB® Forum Software © phpBB Limited
@2016 4DGames. All rights reserved

[ GZIP: Off ]