Exiled Kingdoms
http://exiledkingdoms.com/forum/

Possible bug in quest “Call of the Blood”
http://exiledkingdoms.com/forum/viewtopic.php?f=5&t=16467
Page 1 of 1

Author:  Thalgar [ Thu Jul 26, 2018 8:23 pm ]
Post subject:  Possible bug in quest “Call of the Blood”

Hi, as I was completing this quest, after having killed both the Elder Vampire and the Castle Storme host boss, I was unable to talk with Grissenda‘s sister, or leave via the rune, because neither cage unlocked.

I probably messed up the intended result by accidentally running into the area transition stairs to the Temple of Blood during the battle, after killing one of the bosses and gettin a notice that the quest was updated. I saved at that point thinking the main quest objective had been achieved and reloaded (to boost Grissenda’s hit points a bit), only to find that upon returning to finish off the Elder Vampire, all the monsters in the temple (except the killed boss) had respawned. Am I correct in suspecting that reloading from a quick save was the real problem, and that if I had gone straight back down the respawns would not have occurred, and the quest conditions could still have been met?

At that point I was able to defeat the Eldar Vampire, but discovered to my chagrin that the cages remained closed, and unfortunately the area save and quick save were all from after my error. I now intend to redo the quest to minimize resource costs and will avoid that mistake again, but wonder if the scripting of quest completion conditions can be altered to allow one to escape back upstairs and return to complete the quest (the respawned vampires and undead is OK with me). I think accidentally wandering into the transition shouldn’t nullify the quest itself, and I doubt that part was intended. Possible to fix?

Thanks for a fantastic game—it’s been quite a challenge, even for a noob on casual, but very satisfying to play. Best wishes for continuing success to the developer!

Thanks again,

Thalgar

Author:  DavidBVal [ Fri Jul 27, 2018 7:56 am ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

Thanks for reporting this, I'll look into it. A possible fix for your game: walk up to the castle and wait for 12 game hours, then walk down to the respawned temple. I think the cage will be open. I am not entirely sure, however, and I'll still be away from the code for a week so I can't check.

Author:  MikeB [ Fri Jul 27, 2018 9:53 am ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

It's worth a try, but I'm afraid it won't work. The grate is opened when the Baron dies, but respawns when the area is reset (unless the quest is FULLY finished, i.e. AFTER talking to Eirenda). So if the whole dungeon respawns, the grate of Eirenda's cage will also respawn, but not the Baron. Since there is no way to kill him again, the cage will be locked forever.

And your assumption is right, Thalgar, if you would have returned to the temple without reloading, everything should have worked out just fine. You may try to interact with Eirenda through the closed cage, but I'm not sure whether you can get close enough to make her icon appear.

Author:  DavidBVal [ Fri Jul 27, 2018 10:54 am ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

In any case, you'll be able to complete this after next tech update in August, don't worry.

Author:  Thalgar [ Fri Jul 27, 2018 1:05 pm ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

Wow, thanks for the quick response, David. It’s not a problem for me anymore, as I made another run at the quest, and finished it fairly easily. Knowing where to avoid vampires and using the secret passageway to get to one blood pool and saving the SW one for last got me through to the big fight at the end with most of my health and both restorations intact. A few potions and one hold undead scroll later I finished off both bosses. Hardest part is just getting past the headless undead in the first place. That took more potions and scrolls than all the rest of the dungeon.

Thanks again!

Regards,
Thalgar

Author:  yandersen [ Mon Sep 17, 2018 5:36 pm ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

David, sorry, but this quest seem to be overbugged even now, in version 1.2.1110. My guess is that some parts of progress got saved "globally" or smg... Here is the thing. I saved just before entering the castle, tried to complete it first time to the point where I encountered the baron at the dungeon. But i failed the battle and died. Decided it was too tough for my level. So i reloaded the savegame before entering the castle and moved on. Some time after i decided to try again. But when i entered the castle and so on, i noticed the maps were revealed as if i was there before (but according to active savegame line i wasn't, see?). Then i found the Eirenda's maid' body was missing, but i could talk to the place it should be. Then, in dungeon below, i aggro the baron, but decided to retreat to the upper level to heal up. When i returned, the Baron did not appeared, the Vampire guy ignored my presence and cages were closed. So i had to do it all again in one run from the save outside the castle. Even so, the maid' body was missing and map revealed anyway. Seems like the most bugged quest so far. And too tough, tbh.

Author:  Fredteng [ Thu Nov 15, 2018 3:28 am ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

I'm having the same problem. I killed the two bosses and went back to kill executioner and now the cage won't unlock. Tried leaving and waiting 13 hours. Please help.

https://ibb.co/kEgP5L

Author:  DavidBVal [ Fri Nov 16, 2018 8:40 am ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

Are you the same player that contacted via email?

Not sure what's up with the death script of the baron, but I might add an extra check when you approach the cage on next update.

Author:  SirFency [ Sat Sep 21, 2019 1:22 pm ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

I am experiencing a glitch with this quest. I have completely cleared the entire dungeon but i cannot get the Vampire Elder to engage. I assume its because I left the downstairs area and came back down. Dobros Storme is not there and I cannot clear this quest. I left the area and came back and the Elder Vampire was active again but Dobros is gone. Luckily I saved the game before entering the Castle but its such a long quest to glitch out like this.

Author:  p4ran0id [ Sat Sep 21, 2019 1:53 pm ]
Post subject:  Re: Possible bug in quest “Call of the Blood”

It's definitely not because you left the area, I did it several times.

Have you ever quit the game during that area, like force close or similar? Such glitch can happen if the game get quit during a dialogue or similar. But not if you just leave an area.

Good thing that you have a backup, so use that and don't close the game during any activity.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/